Cheyenne’s default MPT updated to version 2.19

March 15, 2019

Cheyenne’s default MPI library is now MPT 2.19, which is the version that HPE recommends and supports. Versions 2.15 and 2.16 are no longer compatible with system firmware and have been removed from the system. To mitigate failures from existing scripts and job workflows, the mpt/2.15 and mpt/2.16 modules still exist, but they now point to the MPT 2.19 library and issue a message prompting users to upgrade. The mpt/2.15 and mpt/2.16 modules will be deleted later this year. MPT 2.18 is still available on Cheyenne but is no longer supported by HPE.

The parallel libraries netcdf-mpi and pnetcdf using MPT 2.19 are available for the following, supported versions of the Intel compiler: 16.0.3, 17.0.1 (the default), 18.0.5, and 19.0.2. The libraries have also been built for GCC versions 6.3.0, 7.3.0, and 8.1.0, and for PGI 17.9.

Users should update their scripts and recompile executables to use MPT 2.19 as soon as possible.